Email: Issues with Shared Mailboxes in Outlook on the web
Incident Report for Cardiff University
Resolved
Microsoft have now confirmed that they have fully applied the fix, and that normal service has been restored.
Posted Apr 19, 2024 - 13:57 BST
Update
Microsoft have begun to implemented the fix, and are monitoring its progress. A more detailed timeline for full remediation should be available by tomorrow.
Posted Apr 18, 2024 - 10:17 BST
Monitoring
Microsoft have developed a fix for this issue, and are in the process of completing testing ahead of applying it.
Posted Apr 17, 2024 - 10:03 BST
Identified
Microsoft have confirmed that they have identified an issue which can sometimes affect users attempting to access a Shared Mailbox via Outlook on the Web, and they are working on a resolution.

In addition to the possibility of using Outlook classic desktop application as a temporary workaround, Microsoft have advised that the issue can sometimes be overcome by signing out of the session on the web browser and clearing all cookies before using a direct link to the shared mailbox to sign in again
Posted Apr 16, 2024 - 11:06 BST
Investigating
We have been alerted to a possible issue which might be causing difficulties in accessing some shared mailboxes via Outlook on the Web.

Microsoft are reportedly investigating these reports, and we will provide an update once Microsoft indicate their findings.

Any users who experiences any difficulties in accessing a shared mailbox via Outlook on the Web is advised to utilise Outlook classic desktop client if possible, as a temporary workaround measure.
(Users are however reminded that caution should be exercised when sending Welsh or bilingual emails, because Outlook classic desktop can unexpectedly revert to sending from/to @cardiff.ac.uk addresses instead of @caerdydd.ac.uk addresses regardless of what was specified in the from/to/cc/bcc fields)
Posted Apr 15, 2024 - 15:46 BST
This incident affected: Communication & Collaboration (Email & Calendar (Outlook)).