Turnitin
Incident Report for Cardiff University
Resolved
Our suppliers have indicated that the issue with the Turnitin service has now been resolved.

Apologies for any disruption this has caused.
Posted Jan 16, 2023 - 15:57 GMT
Investigating
University IT are aware of an issue with the Turnitin service where there are reports of it being very slow. We are awaiting updates from the suppliers around this issue.

An update will be provided as soon as more information is available.
Posted Jan 16, 2023 - 10:51 GMT
This incident affected: Student Systems (Turnitin).