Manage My Publications unavailable

Incident Report for Cardiff University

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 12:23 BST

Investigating

We are aware of an issue with Manage My Publications. This is currently under investigation and we will provide an update as soon as possible.
Posted Apr 10, 2025 - 11:28 BST
This incident affected: Research (ORCA & Manage My Publications).