myPrint service interruption

Incident Report for Cardiff University

Resolved

The myPrint service has been restored. We apologise for the interruption.
Posted Sep 02, 2026 - 12:20 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2026 - 10:13 BST

Investigating

We are aware of an issue with the myPrint service, which is currently unavailable for many service users. This is currently under investigation.
Posted Sep 02, 2026 - 09:54 BST
This incident affected: Computers, Software, & Printing (Printing, Copying, & Scanning).