Student App

Incident Report for Cardiff University

Resolved

The issue affecting access to the Student App has now been resolved.
Posted Nov 27, 2025 - 08:57 GMT

Investigating

University IT are aware of an issue affecting access to the Student App and technical staff are currently investigating.

An update will be provided as soon as more information is available.
Posted Nov 26, 2025 - 15:37 GMT
This incident affected: Student Systems (Student App).