Email: Intermittent issues accessing Microsoft Outlook on the web via mail.cardiff.ac.uk

Incident Report for Cardiff University

Update

We are continuing to investigate this issue.
Posted Sep 16, 2026 - 10:41 BST

Investigating

We're investigating reports of intermittent issues accessing Microsoft Outlook on the web via mail.cardiff.ac.uk.

If you're affected, you can continue to access your email using Microsoft's direct Outlook web address:
https://outlook.office.com/mail/?realm=cardiff.ac.uk
Posted Sep 16, 2026 - 10:11 BST
This incident affects: Communication & Collaboration (Email & Calendar (Outlook)).