Turnitin - Service Outage
Incident Report for Cardiff University
Resolved
Turnitin UK are reporting the issue is now resolved, however there may be slight delays in submissions being processed as the backlog is cleared.

Turnitin UK offer their apologies for all those impacted by today's incident.
Posted May 10, 2022 - 14:43 BST
Monitoring
Turnitin UK are currently reporting an 'unexpected service incident' with the Turnitin service. The problem is impacting all users of the system, and is not local to Cardiff.

Users may be unable to access the service, experience slower than usual file uploads, and delayed report generation times.

We will continue to monitor the situation and provide updates here as soon as we receive them.

You may wish to subscribe to this incident to automatically receive updates when posted.

Thank you.
Posted May 10, 2022 - 12:14 BST
This incident affected: Student Systems (Turnitin).