Published Applications and Desktops (Horizon) - Access issues

Incident Report for Cardiff University

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 15:47 GMT

Identified

A temporary fix has been implemented while we continue to investigate this issue. Again, we apologise for any inconvenience this is causing.
Posted Mar 13, 2026 - 10:14 GMT

Investigating

Published Applications and Desktops (Horizon)



University IT is aware of an issue with the Published Applications and Desktops Service (Horizon) that is preventing some users from logging in / launching applications.

We are investigating this as a matter of urgency and hope to resume normal service shortly.

We apologise for any inconvenience this is causing.
Posted Mar 13, 2026 - 09:41 GMT
This incident affected: Computers, Software, & Printing (Published Applications (Horizon)).