Large volume of calls to IT Service Desk
Incident Report for Cardiff University
Resolved
Service desk call volumes have now returned back to normal levels. Thank you for your patience during what is always a busy time for our service desk.
Posted Oct 27, 2021 - 09:38 BST
Update
The IT Service Desk is continuing to experience a large volume of calls, which is causing a particular delay in responding to calls submitted via email.

As the Service Desk are very busy, we would recommend looking at the Intranet self help pages in the first instance.

If your issue is urgent and impacts on teaching or a critical, time-sensitive business activity, could you please ensure that you telephone the Service Desk for your call to be addressed. These calls will be prioritised.
Posted Oct 12, 2021 - 09:30 BST
Identified
The IT Service Desk is currently experiencing a large volume of calls, which is causing a particular delay in responding to calls submitted via email.

If your issue is urgent and impacts on teaching or a critical, time-sensitive business activity, could you please ensure that you telephone the Service Desk for your call to be addressed. These calls will be prioritised.
Posted Oct 06, 2021 - 09:38 BST
This incident affected: Help & Support (Service Desk Support (IT single point of contact)).