Published Applications and Desktops (Horizon)

Incident Report for Cardiff University

Resolved

University IT has implemented a fix and normal service has been restored.

Again, we apologise for any inconvenience this caused.
Posted Mar 19, 2026 - 10:04 GMT

Investigating

Published Applications and Desktops (Horizon)



University IT is aware of an issue with the Published Applications and Desktops Service (Horizon) that is preventing users from launching some applications.

We are investigating this as a matter of urgency and hope to resume normal service shortly.

We apologise for any inconvenience this is causing.
Posted Mar 19, 2026 - 08:53 GMT
This incident affected: Computers, Software, & Printing (Published Applications (Horizon)).