Telephony - 'Netcall' call centre service
Incident Report for Cardiff University
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 10:34 GMT
Monitoring
A fix has been implemented and we are monitoring the service. Service remains at risk for 24-Hours whilst we monitor.
Posted Jan 11, 2023 - 15:38 GMT
Update
We are continuing to investigate this issue.
Posted Jan 11, 2023 - 09:33 GMT
Update
We are continuing to investigate this issue.
Posted Jan 11, 2023 - 09:17 GMT
Investigating
We are currently experiencing an issue with the University 'Netcall' service - the technology used to provide call center telephone functionality to several University services, including the IT Service Desk, Student Connect, and Switchboard services.

Whilst the IT Service Desk currently cannot take calls, if you have an urgent issue (e.g. MFA lockout/reset) then please email IT-ServiceDesk@cardiff.ac.uk, making it clear in the email subject line that the issue is urgent.

Those needing to contact Student Connect are reminded of the other methods of contacting the Student Connect team including visiting in person, using the Student Connect Portal, or the online chatbot. These alternative methods of contacting the team are available here:

https://intranet.cardiff.ac.uk/students/health-and-wellbeing/how-to-get-in-touch-for-support-using-student-connect

Engineers are working to resolve the telephony issues, and this page will be updated as soon as further updates become available.

Thank you.
Posted Jan 11, 2023 - 09:14 GMT
This incident affected: Communication & Collaboration (Netcall (Call Centre functionality)).