Worktribe Scheduled Upgrade – 25 February 2026
Completed
The scheduled maintenance has been completed.
Posted Feb 25, 2026 - 19:30 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 25, 2026 - 17:30 GMT
Scheduled
What is being done?
Worktribe will undergo a scheduled upgrade, as part of its routine enhancement cycle.
When is it being done?
25 February 2026, between 17:30 and 19:30 hours.
Who will be affected?
Users of Worktribe.
How will this affect service users?
Worktribe will be unavailable during the above time. No action is required from Worktribe users before or after the upgrade. There will be no impact on existing records, submissions, or work in progress.
For a full list of changes, please visit the documentation on the Worktribe system: Worktribe Help Topics - https://cardiff.worktribe.com/record.jx?recordid=707314
For any queries contact RST@cardiff.ac.uk
Why is it being done?
This release strengthens long term system stability, improves clarity, and ensures continued platform support.
Posted Feb 25, 2026 - 09:21 GMT
This scheduled maintenance affected: Research (Worktribe).