Email / Login issues

Incident Report for Cardiff University

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 09:05 GMT

Monitoring

University IT have now resolved an IT service interruption that affected staff and students within the School of Psychology between approximately 16:00 on 25 February and 11:30 on 26 February.

During this period, access to several University IT services, including email, was unavailable. Emails sent to affected staff and students, both from within and outside the University, would not have been delivered.

Unfortunately, these undelivered messages cannot be identified or retrieved. In these cases, the sender will have received an “undeliverable” notification.If you were expecting an email during this time window, we recommend contacting the sender to request that the message be resent.

We sincerely apologise for the disruption this caused. University IT has reviewed the incident and is implementing measures to prevent a similar occurrence in future.

Thank you for your understanding.
Posted Feb 26, 2026 - 12:06 GMT

Update

The incident appears to be specific to the School of Psychology, impacting both staff and students. Engineers are currently working to resolve the issue.

If staff or students outside PSYCH are experiencing issues, please contact the IT Service Desk as your issue may not be related to this incident.
Posted Feb 26, 2026 - 09:44 GMT

Identified

We are aware a number of staff and students are experiencing issues logging into email, sending or receiving email, and logging into other University services including VPN.

The issue is currently being investigated and updates will be provided here.
Posted Feb 26, 2026 - 08:59 GMT
This incident affected: Network (Wireless Network Connectivity, Virtual Private Networks (VPN)) and Communication & Collaboration (Email & Calendar (Outlook)).