Unplanned Network Outage - QUEENS BUILDINGS

Incident Report for Cardiff University

Identified

The majority of the network at the Queens site has been restored; however, some areas are still affected. University IT and Estates are working on a solution as a matter of urgency.
Posted Dec 18, 2025 - 09:52 GMT

Investigating

University IT is aware of an issue with the University Network within the Queens Buildings, and technical staff are currently investigating.

Further updates will follow as more information becomes available.

We apologise for any inconvenience this is causing.
Posted Dec 17, 2025 - 16:09 GMT
This incident affects: Network (Wired Network Connectivity, Wireless Network Connectivity).