Email: Issues accessing mailboxes and delays in sending & receiving emails
Incident Report for Cardiff University
Resolved
Microsoft have confirmed that they have migrated all affected users onto alternative resource and have identified the root cause of the issue which was related to a power incident on a portion of their infrastructure.

All users should once again be enjoying normal service.
Posted Jun 22, 2022 - 16:32 BST
Identified
Microsoft have reported that they are aware of an issue affecting some of their customers in Europe which can cause users difficulties in accessing their mailboxes, as well as delays in sending and receiving emails.

Microsoft are reconfiguring their systems to migrate affected users onto alternative healthy infrastructure whilst they investigate the cause of the issue.
Posted Jun 21, 2022 - 12:45 BST
This incident affected: Communication & Collaboration (Email & Calendar (Outlook)).