Email: Issue with shared mailboxes & calendars and delegate access
Incident Report for Cardiff University
Resolved
This incident has been resolved
Posted Sep 14, 2022 - 12:00 BST
Monitoring
Microsoft have released a feature update called "Shared Calendar Improvements" for Outlook which amongst other benefits should help with changes being propagated swiftly, and should address the issues users have been reporting in this incident.

Guidance and step-by-step instructions on how to activate this new feature can be found at https://support.microsoft.com/en-us/office/outlook-calendar-sharing-updates-c3aec5d3-55ce-4cea-84b0-80aab6d8dc26
Users who have still been experiencing any issues with shared calendars are encouraged to apply the new feature to their Outlook application.

More information on how Microsoft have altered the technology they use for shared calendars and the impact that has can be found at https://support.microsoft.com/en-us/office/calendar-sharing-in-microsoft-365-b576ecc3-0945-4d75-85f1-5efafb8a37b4
Posted Jul 11, 2022 - 09:46 BST
Investigating
We received reports that some users have been encountering issues with shared mailboxes & calendars, and their delegate access.

Some of the reported unusual behaviours include created/updated entries not propagating or disappearing, error messages, access issues, and Outlook crashing.

We are currently investigating this issue and will be working with Microsoft on identifying workarounds, the root cause, and resolutions.

Ben Rowett - IT Service Manager
Posted Jun 01, 2022 - 10:34 BST
This incident affected: Communication & Collaboration (Email & Calendar (Outlook)).