We have updated the Manage My Publications interface to make clear that the Web of Science lookup and import feature is no longer available via Manage My Publications due to a change in the way Web of Science provide their records.
The other deposit features in MMP continue to be available as normal.
Posted Apr 03, 2025 - 11:12 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 02, 2025 - 17:28 BST
Investigating
We are currently investigating an issue with Manage My Publications, the research publications quick deposit application. The link to Web of Science in MMP is currently broken, and this is hampering upload of publications data to ORCA from Web of Science. Other MMP deposit functionality appears to be unaffected.
An update will be provided as soon as more information is available.
Posted Mar 18, 2025 - 09:57 GMT
This incident affected: Research (ORCA & Manage My Publications).