Cloudflare outage impacting university systems

Incident Report for Cardiff University

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 15:28 GMT

Update

Cloudflare has implemented a fix and is monitoring the results.
Posted Dec 05, 2025 - 10:40 GMT

Monitoring

Cloudflare outage impacting university systems



Cloudflare has announced a global issue which is affecting some university systems including the staff and student intranet and the public website. Other systems may be impacted.

We will continue to monitor the situation and provide updates here.

We apologise for any inconvenience this is causing.
Posted Dec 05, 2025 - 09:26 GMT
This incident affected: Public Website & Intranet (Public Website (Squiz), Intranet (Squiz)) and Help & Support (IT Portal (Self Service ticket logging)).