Service Desk Ticketing System (ASM): Performance and Login issues

Incident Report for Cardiff University

Update

Further investigations were undertaken into the slow performance of the system, and our provider has recently identified what they believe to be the underlying root cause.
Remediation has subsequently been applied, and normal service operation appears to have been restored, though monitoring will continue over the weekend.
Posted Apr 10, 2026 - 16:44 BST

Update

Some reports continued regarding slower than expected operation of the service, and additional mediation has been attempted in response.
Our engineers and our provider are continuing to monitor and assess the situation.
Posted Apr 09, 2026 - 08:58 BST

Monitoring

Our provider has completed their initial investigations, and have applied a remedy to fix the issues being experienced.

Normal service has been restored, but performance is continuing to be monitored to ensure the fix has been fully effective.
Posted Apr 08, 2026 - 11:12 BST

Investigating

We have been made aware of issues impacting the Service Desk ticketing system (ASM), including reports of very slow processing and not being able to complete the login process.
The issue has been raised and escalated with our third-party provider, who are undertaking investigations.

Issues with failing to log in can be intermittent, and so repeated attempts can sometimes result in success.

We will provide updates as our provider proceeds with their investigations.
Posted Apr 08, 2026 - 10:54 BST
This incident affects: Help & Support (Service Desk Support (IT single point of contact)).