Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 29, 2023 - 16:00 BST
Scheduled
PeopleXD Backoffice and Portal - Rollover of annual leave entitlement
What is being done? The Human Resources Department is running the rollover of staff annual leave entitlement on the PeopleXD production environment.
When is this being done? Work commences at 16:00, Friday, 29th September and completes at 09:00, Tuesday, 3rd October.
Who will be affected? All PeopleXD Backoffice and Portal users.
How will this affect service users? The PeopleXD Backoffice and Portal services will be unavailable during the stated period. Users will be unable to log in to book leave, check payslips etc. during this time.
Why is this being done? This is essential maintenance to ensure your annual leave entitlement is updated and correctly displayed.
Kevin Villis - Service Manager
Posted Sep 26, 2023 - 08:56 BST
This scheduled maintenance affected: HR & Student Record Systems (PeopleXD (Core HR)).