Squiz - Public Website and Intranet Performance Issues

Incident Report for Cardiff University

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 12:56 GMT

Investigating

University IT has reported performance issues relating to the public website (cardiff.ac.uk) and intranet (intranet.cardiff.ac.uk) to our service provider, Squiz.

This has been escalated within Squiz and we are awaiting their response.

We apologise for any inconvenience this is causing.
Posted Feb 25, 2026 - 10:37 GMT
This incident affected: Public Website & Intranet (Public Website (Squiz), Intranet (Squiz)).