Turnitin - slowness
Incident Report for Cardiff University
Resolved
Our suppliers have indicated that the issue affecting the Turnitin has now been resolved.
Posted Mar 23, 2023 - 14:07 GMT
Identified
The suppliers have identified the issue and are in the process of clearing the backlog.

Further updates will be provided in due course.
Posted Mar 23, 2023 - 14:03 GMT
Investigating
University IT have received an alert from the suppliers of Turnitin stating that users of the service may find that submissions are slower to upload and generate a Similarity Report.

An update will be provided as soon as more information is available.
Posted Mar 23, 2023 - 11:56 GMT
This incident affected: Student Systems (Turnitin).