Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 04, 2025 - 17:00 GMT
Scheduled
Oracle EBS – emergency security maintenance – 17:00 to 18:00 on Tuesday, 4th November 2025
What is being done? We have been alerted to a critical security vulnerability within our Oracle EBS service. Our partner will undertake emergency maintenance on the Oracle EBS service in order apply a patch to mitigate this vulnerability.
When is it being done? From 17:00 to 18:00 today - Tuesday, 4th November 2025.
Who will this affect? All Oracle EBS and some Business Objects users.
How will this affect users? For any user still logged into the system their current session (transaction/page) may terminate or show a brief “Page cannot be displayed” or “Your session has expired” message. Those impacted can usually just refresh or log back in.
However, to avoid losing work/progress, users are advised to log out of Oracle EBS before 17:00 today - Tuesday, 4th November 2025.
Why is it being done? This is emergency maintenance to ensure the service remains secure.
We apologise for any inconvenience this causes.
Posted Nov 04, 2025 - 12:35 GMT
This scheduled maintenance affected: Finance Systems (Financial and Procurement System (Oracle-EBS)).