Microsoft Teams: Possible disruption to Teams application

Incident Report for Cardiff University

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 11:26 BST

Investigating

Microsoft have announced that they are aware of an issue impacting some users of the Microsoft Teams app, which results in them receiving an error message when attempting to launch the app.

If encountered, the error message states "We couldn't connect to this app". Users can bypass this error message and launch the app by clicking the "Activity" or "Chat" buttons on the left side of the screen.

It is not clear at this point whether any users in Cardiff University have been affected by this issue, and Microsoft continue to test the fix they have developed ahead of applying it to everyone.
Posted Aug 08, 2025 - 10:43 BST
This incident affected: Communication & Collaboration (Microsoft Teams).