School Management Application - Unplanned outage

Incident Report for Cardiff University

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 12:50 GMT

Investigating

School Management Application

University IT is aware of an issue impacting the School Management Application and is working to resolve this incident as quickly as possible.

We apologise for any inconvenience this is causing.

Posted Nov 26, 2025 - 09:24 GMT