MyTimetable via the Student App

Incident Report for Cardiff University

Resolved

The issue affecting access to MyTimetable via the Student App has been resolved.

Apologies for any inconvenience this has caused.
Posted Oct 03, 2023 - 16:31 BST

Investigating

University IT are aware of an issue accessing the MyTimetable service via the Student App, and technical staff are currently investigating.

If you wish to view your timetable, please use the MyTimetable website until this issue is resolved.

An update will be provided as soon as more information is available.
Posted Oct 02, 2023 - 16:01 BST
This incident affected: Student Systems (Student Timetable).