Calendar: Intermittent issues updating/cancelling calendar entries in Outlook desktop
Incident Report for Cardiff University
Resolved
The application of the fix has now completed, and the service has returned to normal.

If you experience a conflict issue with calendar entries, please follow the steps within "Workaround 2" in the following Microsoft help article:
https://support.microsoft.com/en-us/office/outlook-shows-conflict-errors-when-updating-or-cancelling-meetings-69c26227-40ef-4377-8f12-1749fcaad2ad

If you have duplicate copies of a calendar entry, please follow the steps within "Workaround 3" in the following Microsoft help article:
https://support.microsoft.com/en-us/office/outlook-shows-conflict-errors-when-updating-or-cancelling-meetings-69c26227-40ef-4377-8f12-1749fcaad2ad
Posted Jul 15, 2024 - 10:08 BST
Monitoring
Microsoft have identified the necessary fix, and are in the process of deploying it across their considerable infrastructure.

Once the fix has finished deploying, and following a period of monitoring to ensure its effectiveness in remediating the issue, Microsoft will provide a further announcement in due course to indicate that the incident is resolved. We will provide an update on this as soon as possible.
Posted Jul 09, 2024 - 10:16 BST
Identified
Microsoft have confirmed that an issue with Outlook desktop can intermittently affect some users, preventing them from updating or cancelling calendar entries.

As a temporary workaround, users can utilise Outlook on Web which is not affected by this.

Please note that whilst the New Outlook desktop client is also not affected, it is still being developed and can cause issues with certain functionality such as interacting with shared mailboxes or delegated access.
Posted Jun 28, 2024 - 11:47 BST
This incident affected: Communication & Collaboration (Email & Calendar (Outlook)).