A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2025 - 12:54 GMT
Identified
We are still experiencing issues with certain outlets located in the lower half of the building. Engineers are on site to resolve the issue.
Posted Nov 25, 2025 - 09:01 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 13:47 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 24, 2025 - 10:34 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 09:58 GMT
Investigating
University IT is aware of an issue with the University Network based in the Dental Hospital, Heath Park Campus, and technical staff are currently investigating.
Further updates will follow as more information becomes available.
We apologise for any inconvenience this is causing.
Posted Nov 24, 2025 - 09:56 GMT
This incident affected: Network (Wired Network Connectivity, Wireless Network Connectivity).