Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2025 - 07:45 BST
Scheduled
Intranet and Public Website - Major Upgrade (Squiz) - 27th August 2025
What is being done? Squiz are migrating our current service onto the Digital Experience Platform (DXP). This is a major upgrade to the content management system that provides our public website and staff/student intranet sites. The change will introduce new functionality and provide opportunities for development that are not available within the existing service.
When is it being done? Squiz will make the new service available around 08:00 on Wednesday, 27th August 2025.
Who will this affect? All users of the public website and/or the staff/student intranet sites.
How will this affect service users? There is likely to be some disruption during the switch to the new service. Users logged in to the intranet sites may be prompted to log back in and/or may need to clear cache and cookies to access the updated service. Your first log in to the intranet after the switch may be slower than usual. The anticipated disruption should last no longer than 30 minutes, but performance might be impacted for several hours.
For Squiz editors only: There will be a content edit freeze during the entire window. This has been communicated directly to editors and senior stakeholders across the university.
Why is it being done? This is required to maintain support from the service provider and will provide new functionality and increased resilience to the service.
Posted Aug 26, 2025 - 15:25 BST
This scheduled maintenance affected: Public Website & Intranet (Public Website (Squiz), Intranet (Squiz)).