myPrint Update Cancelled – Tuesday 31 March

Scheduled for Mar 31, 15:30 BST  -  Apr 2, 14:00 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 30, 2026 - 13:41 BST

Update

The myPrint (print, copy and scan) service update on Tuesday 31 March has been cancelled (https://intranet.cardiff.ac.uk/students/it-support/print-copy-scan/myPrint-printing-service).

As a result, printing WILL be available in the site libraries on this date.

However, the payment gateway used to add credit to your myPrint account will be unavailable from 15:30 Tuesday 31 March to 14:00 Thursday 2 April. If you need to top up your printing account, please instead visit a Cardiff University library during staffed hours, where staff will be able to help.

Why is this being done?
The interruption to the print payment gateway is due to supplier issues, and we are working hard to resolve this as soon as possible.

Note:
As previously advertised, the Staff Print service available in staff areas, and the Library Print Unit managed printing service (https://intranet.cardiff.ac.uk/students/it-support/print-copy-scan/university-print-services , print@cardiff.ac.uk), WILL continue to be available as normal during this time.
Posted Mar 30, 2026 - 13:39 BST

Scheduled

The myPrint (print, copy and scan) service update on Tuesday 31 March has been cancelled (https://intranet.cardiff.ac.uk/students/it-support/print-copy-scan/myPrint-printing-service).

As a result, printing WILL be available in the site libraries on this date.

However, the payment gateway used to add credit to your myPrint account will be unavailable from 15:30 Tuesday 31 March to 14:00 Thursday 2 April. If you need to top up your printing account, please instead visit a Cardiff University library during staffed hours, where staff will be able to help.

Why is this being done?
The interruption to the print payment gateway is due to supplier issues, and we are working hard to resolve this as soon as possible.

Note:
As previously advertised, the Staff Print service available in staff areas, and the Library Print Unit managed printing service (https://intranet.cardiff.ac.uk/students/it-support/print-copy-scan/university-print-services , print@cardiff.ac.uk), WILL continue to be available as normal during this time.
Posted Mar 26, 2026 - 12:47 GMT
This scheduled maintenance affects: Computers, Software, & Printing (Printing, Copying, & Scanning).