Student Timetable certificate error

Incident Report for Cardiff University

Resolved

The issue affecting access to the Student Timetable service has been resolved.
Posted Jul 14, 2025 - 09:10 BST

Investigating

University IT are aware of an issue with the Student Timetable service, where users are presented with a certificate error. Technical staff are currently investigating.

An update will be provided as soon as more information is available.
Posted Jul 11, 2025 - 09:46 BST
This incident affected: Student Systems (Student Timetable).